Tech Support

asprin

Mr. Fixit
Admin
Sportsbookie
India
PlanetCricket Award Winner
X Rebels
Joined
Sep 3, 2012
Location
Hyderabad, India
Profile Flag
India
Online Cricket Games Owned
  1. Don Bradman Cricket 14 - Steam PC
Just enabled Discover in my Google App and what I see :crylaugh:
View attachment 267258

1. Open your Google App, tap on top right corner on your account.
2. Select Settings, and then select Language and region, you can find Discover Language there.
3. If it is not there then get back Delete your account activity/ Interests. Make sure that App and Web activity in ON.
4. After this Discover Language option should appear and set it according to your preference.

Hope this'll work.
Google App is fine. I'm able to change the language.

The problem is that I'm unable to do the same in Chrome browser. I rarely use the Google app, yhe browser on the other hand is heavily used.
 

Life Warrior

Staff Member
Moderator
Fantasy Cricket Team
PlanetCricket Award Winner
Birmingham Phoenix
TPCL Titans
Joined
Nov 3, 2017
Location
India
Profile Flag
India
Online Cricket Games Owned
  1. Don Bradman Cricket 14 - Steam PC
Google App is fine. I'm able to change the language.

The problem is that I'm unable to do the same in Chrome browser. I rarely use the Google app, yhe browser on the other hand is heavily used.
Have you tried clearing your interest/ Activity and the Chrome App Data.
 

Life Warrior

Staff Member
Moderator
Fantasy Cricket Team
PlanetCricket Award Winner
Birmingham Phoenix
TPCL Titans
Joined
Nov 3, 2017
Location
India
Profile Flag
India
Online Cricket Games Owned
  1. Don Bradman Cricket 14 - Steam PC
Or in Chrome App, go to settings > Language and then in Translation settings add Telugu to Automatically translate these language to English.
This might not fix your issue but surely help you.
 

asprin

Mr. Fixit
Admin
Sportsbookie
India
PlanetCricket Award Winner
X Rebels
Joined
Sep 3, 2012
Location
Hyderabad, India
Profile Flag
India
Online Cricket Games Owned
  1. Don Bradman Cricket 14 - Steam PC
A bit of a trivial thing but my discover on Google Chrome has changed to regional language and I cannot, for the life of me, figure out:

(a) Why it changed?
(b) How do I go back to English?

View attachment 267245
I turned it off for 1 day. Switched it back on the next day and viola! I had the articles in English again :wow:
 

Users who are viewing this thread

Top