Using Proton or Wine to play EA Cricket 07 under Linux


School Cricketer
Feb 13, 2010
Online Cricket Games Owned
I created a thread to discuss using a gnu/linux based distro to play EA Cricket 07. I stopped using Windows as a daily driver a long time ago and currently using Ubuntu 20.04. I rarely have time to play so I sporadically mess around with Lutris/Wine/Proton.

Several years ago the game ran fine but my recent attempts failed at getting the game to run. I am planning to write an installer script using Lutris ( The current roadblock is that when I try to install the game, Wine does not detect the Drive in the CD. I tested the install under a Windows 10 Virtual Machine and the game installs from the CD. This must be some configuration error on my side.

Using Proton: I haven't tried installing from Proton yet but I will try that. For a workaround, I copied the Windows installed folder into the "steam/steamapps/common" folder. I added the game as a non-steam game and forced the compatibility mode to use Proton experimental. I created a compatibility folder in the "steam/steamapps/compatdata" by copying a random compatdata into the folder. I set the game to launch in the compatdata folder. Clicking on 'Play' launches the game but it hangs immediately (ie it opens a black screen. I will have to investigate which dll's or other requirements are needed.

If anyone else is using Linux feel free to expand in this thread.
Last edited:

Na Maloom Afraad

Khana Badosh
PlanetCricket Award Winner
TCPL Bad Boys
Apr 21, 2012
Profile Flag
I need to find a way to run C07 on Catalina as well. I know this thread is about Linux but I need to put this out there. I used a Wineskin wrapper before I updated to Catalina and it ran as smoothly as it did/does on Windows. But ever since the upgrade to Catalina, Wine stopped working because Catalina apparently no longer supports 32-bit programs. I tried an unofficial build for Wineskin but it does not seem to work either. Like you mentioned, it does not find or connect with any directory that's not present within the wrapper.

Been experiencing the same thing when I try to run other programs as well, is that a Wine problem or is running C07 on Catalina impossible without installing a virtual machine or splitting the hard disk to install Windows?


School Cricketer
Feb 13, 2010
Online Cricket Games Owned
You can create a 32bit prefix with wine. I do not think it is a wine problem, that is if it works the same under a Mac as under Linux.


School Cricketer
Feb 13, 2010
Online Cricket Games Owned
Successfully launched EA Sports Cricket 07 adding it as a non-steam app and using proton.

The steps I followed, I copied my installed directory from a windows install to the "steam/steamapps/common" folder. I copied an existing compatdata to "steam/steamapps/compatdata". I used the "Rugby World Cup 2015" compatdata folder and I renamed it to "proton".

I then added the game exe as a non-steam app and set the target folder to the steam directory:
"~/steam/steamapps/common/EA SPORTS(TM) Cricket 07/cricket07.exe"

I set the start in folder to the relevant directoy
"~/steam/steamapps/common/EA SPORTS(TM) Cricket 07/"

In compatibility mode I set the proton version to experimental.

The game did not launch so I tried to run proton via the terminal and link to the game by using the below command:

I used this post as a reference:

I first declared the compat directory in my bash using the below command
nano ~/.bashrc

I added the below lines at the bottom of the file
# Proton
export STEAM_COMPAT_DATA_PATH=~/games/steam/steamapps/compatdata/proton

I saved the file and restarted my machine

I then tried to run the game

"~/games/steam/steamapps/common/Proton - Experimental/proton" run "~/games/steam/steamapps/common/EA SPORTS(TM) Cricket 07/Cricket07.exe"

I saw an error relating to the fonts and install the missing freetype font:
"sudo apt install libfreetype6:i386"

If I use Steam to launch EA Sports Cricket 07 it launches and plays as per normal. I can save the profile.

I have a separate drive for my Steam library, however Steam does not use this drive for the compatdata. The save files are stored in the compatdata in the home folder not in the separate library folder I created, even though it is set as the default library:
'~/.steam/steam/steamapps/compatdata' It creates a folder with a random number.

I successfully installed the game by adding the setup.exe as in the above process and ran the install setup. I will detail it in another post but basically the game is installed into the compatdata folder as described in the paragraph above. Steam creates a new compatdata folder.

Left to do:
Test if the mods works.
Last edited:

Users who are viewing this thread